Install Skype on Ubuntu 16.04

I use Skype regularly for video calling. It works excellent even when I call from my cell phone. Nowadays there are several other applications are available too for video calling. But still now I’ve found Skype is the best to handle noise and consistent during longer calls.

Recently I’d upgraded my OS to Ubuntu 16.04. As Skype is not available in Ubuntu repository so again I was looking for the Skype installation details. Hence just to make good use of my time on the next iteration- here is the post.

Steps:

  • $ wget http://download.skype.com/linux/skype-ubuntu-precise_4.3.0.37-1_i386.deb
  • $ sudo dpkg --add-architecture i386
  • $ sudo apt-get update
  • $ sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb
    Selecting previously unselected package skype:i386.
    (Reading database ... 245256 files and directories currently installed.)
    Preparing to unpack skype-ubuntu-precise_4.3.0.37-1_i386.deb ...
    Unpacking skype:i386 (4.3.0.37-1) ...
    dpkg: dependency problems prevent configuration of skype:i386:
    skype:i386 depends on libc6 (>= 2.3.6-6~).
    skype:i386 depends on libc6 (>= 2.7).
    skype:i386 depends on libgcc1 (>= 1:4.1.1).
    skype:i386 depends on libqt4-dbus (>= 4:4.5.3).
    skype:i386 depends on libqt4-network (>= 4:4.8.0).
    skype:i386 depends on libqt4-xml (>= 4:4.5.3).
    skype:i386 depends on libqtcore4 (>= 4:4.7.0~beta1).
    skype:i386 depends on libqtgui4 (>= 4:4.8.0).
    skype:i386 depends on libqtwebkit4 (>= 2.2~2011week36).
    skype:i386 depends on libstdc++6 (>= 4.2.1).
    skype:i386 depends on libx11-6.
    skype:i386 depends on libxext6.
    skype:i386 depends on libxss1.
    skype:i386 depends on libxv1.
    skype:i386 depends on libssl1.0.0.
    skype:i386 depends on libpulse0.
    skype:i386 depends on libasound2-plugins.
    dpkg: error processing package skype:i386 (–install):
    dependency problems – leaving unconfigured
    Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) …
    Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160523-0ubuntu1) …
    Rebuilding /usr/share/applications/bamf-2.index…
    Processing triggers for gnome-menus (3.13.3-6ubuntu3) …
    Processing triggers for desktop-file-utils (0.22-1ubuntu5) …
    Processing triggers for mime-support (3.59ubuntu1) …
    Processing triggers for dbus (1.10.6-1ubuntu3) …
    Errors were encountered while processing:
    skype:i386

This error gets triggered when there are some dependency issues. Easy to resolve-

  • $ sudo apt-get -f install

Now Skype should be available in launcher. Otherwise can be started from terminal too.

  • $ skype
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s